Leave a Reply

18 Comments on "Spring Boot Quick Start 9 – Starting a Spring Boot application"

Notify of
avatar

bbvkishore
Guest
bbvkishore
2 days 19 hours ago

To me, it did not work until I add the spring boot maven plugin in pom.xml

<build>
<plugins>
<plugin>
<groupId>org.springframework.boot</groupId>
<artifactId>spring-boot-maven-plugin</artifactId>
</plugin>
</plugins>
</build>

gandhar vaidya
Guest
gandhar vaidya
13 days 11 hours ago
Get this in the console and the application won't start as web app2017-03-17 01:25:54.107 INFO 3272 — [ main] io.springbootstarter.SpringCourseApi : Starting SpringCourseApi on gandy with PID 3272 (C:Springworkspacecourse-apitargetclasses started by gandhar in C:Springworkspacecourse-api)2017-03-17 01:25:54.110 INFO 3272 — [ main] io.springbootstarter.SpringCourseApi : No active profile set, falling back to default profiles: default2017-03-17 01:25:54.233 INFO 3272 — [ main] s.c.a.AnnotationConfigApplicationContext : Refreshing org.springframework.context.annotation.AnnotationConfigApplicationContext@be64738: startup date [Fri Mar 17 01:25:54 MDT 2017]; root of context hierarchy2017-03-17 01:25:55.883 INFO 3272 — [ main] o.s.j.e.a.AnnotationMBeanExporter : Registering beans for JMX exposure on startup2017-03-17 01:25:55.906 INFO 3272 — [ main] io.springbootstarter.SpringCourseApi : Started SpringCourseApi in… Read more »
Ernest Chechelski
Guest
Ernest Chechelski
20 days 4 hours ago

I had some problems with maven. I solved this using that stackoverflow post: stackoverflow.com/questions/41052805/spring-boot-with-spring-boot-starter-web-fails-to-compile-in-maven 🙂

ahmad solehin
Guest
ahmad solehin
25 days 6 hours ago

thx

Himanshu Suman
Guest
Himanshu Suman
26 days 13 minutes ago

its not taking "@SpringBootApplication" but @SpringBootConfigurationand this is not working

Himanshu Suman
Guest
Himanshu Suman
26 days 52 minutes ago

its showing "Error: Could not find or load main class spring.api.MainDemo"help plz…

Anuj Sachan
Guest
Anuj Sachan
27 days 6 hours ago

hello kaushiki changed spring-boot-starter-parent to 1.4.2. release but i am not able to import SpringApplication.run showing me red line.. how to ressolve it ?

Anusha Kota
Guest
Anusha Kota
2 months 4 days ago
hi,I had to change version to 1.4.3 in pom.xml to resolve import issues, but now I am getting below exception when i run:Exception encountered during context initialization – cancelling refresh attempt: org.springframework.context.ApplicationContextException: Unable to start embedded container; nested exception is org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'tomcatEmbeddedServletContainerFactory' defined in class path resource [org/springframework/boot/autoconfigure/web/EmbeddedServletContainerAutoConfiguration$EmbeddedTomcat.class]: Initialization of bean failed; nested exception is org.springframework.beans.factory.UnsatisfiedDependencyException: Error creating bean with name 'org.springframework.boot.autoconfigure.web.HttpEncodingAutoConfiguration': Unsatisfied dependency expressed through constructor parameter 0; nested exception is org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'spring.http.encoding-org.springframework.boot.autoconfigure.web.HttpEncodingProperties': Initialization of bean failed; nested exception is javax.validation.ValidationException: Unable to create a Configuration, because no Bean… Read more »
Sanket Kudalkar
Guest
Sanket Kudalkar
15 days 12 hours ago

Just change your parent version to 1.5.2.RELEASE<parent> <groupId>org.springframework.boot</groupId> <artifactId>spring-boot-starter-parent</artifactId> <version>1.5.2.RELEASE</version> </parent>

Nóra Hajdú
Guest
Nóra Hajdú
2 months 24 days ago
bbvkishore
Guest
bbvkishore
2 days 19 hours ago

Yep. Thank you. Make sure we clean up .m2 folder in Users before we start this project. Otherwise .m2 repo seems to be corrupted. After removing .m2/org/spring … you can select pom.xml, Run As, maven install.. which should do the trick.

Peace
Guest
Peace
2 months 26 days ago

I think that you will have to hover over that red sign and then you will see few options. Choose the import option and double click it.It will add an import statement. I hope it works for you. Thanks

wpDiscuz