Leave a Reply

40 Comments on "Spring Boot Quick Start 9 – Starting a Spring Boot application"

Notify of
avatar

Amit Kumar
Guest
Amit Kumar
2 days 12 hours ago

Error: Could not find or load main class

Marinakulichok
Guest
Marinakulichok
6 days 13 hours ago

You can use Jetty instead of Tomcat"The Spring Boot starters (spring-boot-starter-web in particular) use Tomcat as an embedded container by default. You need to exclude those dependencies and include the Jetty one instead. Spring Boot provides Tomcat and Jetty dependencies bundled together as separate starters to help make this process as easy as possible."docs.spring.io/spring-boot/docs/current/reference/html/howto-embedded-servlet-containers.html#howto-use-jetty-instead-of-tomcat

Thrinath Sf
Guest
Thrinath Sf
16 days 40 minutes ago

I tried the same but unable to start. Got below exception:java.lang.IllegalStateException: ApplicationEventMulticaster not initialized – call 'refresh' before multicasting events via the context: org.springframework.boot.context.embedded.AnnotationConfigEmbeddedWebApplicationContext…………………………Caused by: java.lang.NoClassDefFoundError: com/fasterxml/classmate/TypeResolverI tried by changing different versions and added plugin: spring-boot-maven-plugin but NO use.Can anyone help with this?

nikhil nagireddy
Guest
nikhil nagireddy
21 days 8 hours ago

getting this:::::::>>Your ApplicationContext is unlikely to start due to a @ComponentScan of the default package.

Kwstas Antoniou
Guest
Kwstas Antoniou
23 days 20 hours ago

hello i am getting that erro : Description Resource Path Location TypeArchive for required library: 'C:/Users/cliff/.m2/repository/org/springframework/spring-core/4.3.9.RELEASE/spring-core-4.3.9.RELEASE.jar' in project 'DemoApp' cannot be read or is not a valid ZIP file DemoApp Build path Build Path Problem

Navya Sri
Guest
Navya Sri
1 month 16 days ago

java.net.BindException: Address already in use: bindI got this error, pls help me

Ayan Dutta
Guest
Ayan Dutta
1 month 19 days ago

Hi Guys, I think my port 8080 is already in use. Can you tell me how to change the default port of Spring Boot integrated Tomcat server? I am getting the below error while trying to run the application:-"The Tomcat connector configured to listen on port 8080 failed to start. The port may already be in use or the connector may be misconfigured."

Arkadiusz Lipski
Guest
Arkadiusz Lipski
1 month 7 days ago

change the port with adding a file called application.properties to the resources folder. Inside the file just write:server.port = 8081or whatever port you need or want.

Sharat C
Guest
Sharat C
1 month 21 days ago

+javabrains Many of you are getting errors. Here's the fix: Kindly delete your .m2/repository folder, close the project, (if possible IDE) and then open it, run the class file. It shall work properly.

Thrinath Sf
Guest
Thrinath Sf
16 days 30 minutes ago

You are just awesome bro. Thank you so much…

Sushruth Lokam
Guest
Sushruth Lokam
1 month 23 days ago

Hi Koushik, Am getting below errorAPPLICATION FAILED TO START*************************Description:The Bean Validation API is on the classpath but no implementation could be foundAction:Add an implementation, such as Hibernate Validator, to the classpathwhat to do?

Alex Tatulescu
Guest
Alex Tatulescu
24 days 1 hour ago

Add the following to pom.xml : <dependency> <groupId>org.springframework.boot</groupId> <artifactId>spring-boot-starter-web</artifactId> <exclusions> <exclusion> <groupId>org.hibernate</groupId> <artifactId>hibernate-validator</artifactId> </exclusion> </exclusions> </dependency>

JeanScuba
Guest
JeanScuba
1 month 29 days ago

<version>1.5.2.RELEASE</version> clears all the server start errors.

Alexandre Formagio
Guest
Alexandre Formagio
1 month 2 days ago

I had this problem: SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".SLF4J: Defaulting to no-operation (NOP) logger implementationSLF4J: See www.slf4j.org/codes.html#StaticLoggerBinder for further details.Exception in thread "main" java.lang.NoClassDefFoundError: ch/qos/logback/classic/joran/JoranConfigurator at java.lang.Class.getDeclaredConstructors0(Native Method) at java.lang.Class.privateGetDeclaredConstructors(Class.java:2671) at java.lang.Class.getConstructor0(Class.java:3075) at java.lang.Class.getConstructor(Class.java:1825) at org.springframework.boot.logging.LoggingSystem.get(LoggingSystem.java:126) at org.springframework.boot.logging.LoggingSystem.get(LoggingSystem.java:117) at org.springframework.boot.logging.LoggingApplicationListener.onApplicationStartedEvent(LoggingApplicationListener.java:225) at org.springframework.boot.logging.LoggingApplicationListener.onApplicationEvent(LoggingApplicationListener.java:205) at org.springframework.context.event.SimpleApplicationEventMulticaster.invokeListener(SimpleApplicationEventMulticaster.java:166) at org.springframework.context.event.SimpleApplicationEventMulticaster.multicastEvent(SimpleApplicationEventMulticaster.java:138) at org.springframework.context.event.SimpleApplicationEventMulticaster.multicastEvent(SimpleApplicationEventMulticaster.java:121) at org.springframework.boot.context.event.EventPublishingRunListener.started(EventPublishingRunListener.java:63) at org.springframework.boot.SpringApplicationRunListeners.started(SpringApplicationRunListeners.java:48) at org.springframework.boot.SpringApplication.run(SpringApplication.java:304) at org.springframework.boot.SpringApplication.run(SpringApplication.java:1186) at org.springframework.boot.SpringApplication.run(SpringApplication.java:1175) at io.javabrains.springbootstarter.CourseApiApp.main(CourseApiApp.java:10)Caused by: java.lang.ClassNotFoundException: ch.qos.logback.classic.joran.JoranConfigurator at java.net.URLClassLoader.findClass(URLClassLoader.java:381) at java.lang.ClassLoader.loadClass(ClassLoader.java:424) at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:335) at java.lang.ClassLoader.loadClass(ClassLoader.java:357) … 17 moreYour advice solved my problem. Thanks

Shyam Suthar
Guest
Shyam Suthar
1 month 16 days ago

Thanks i had same problem updating to 1.5.2 resolved server start error

1 2 3
wpDiscuz